Skip to main content
CVE-2026-0947VulnerabilityPublished

CVE-2026-0947: Drupal AT Internet Piano Analytics · "Cross-site Scripting"

Affects Drupal AT Internet Piano AnalyticsSource CVE Database V5

0

Not known to be exploited · CVSS 4.8 Medium : upgrade to 2.3.1 or 1.0.1 when convenient.

Data as of 26 Oct 2026, 06:15 UTC

CVSS 3.1 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.3.1, 1.0.1
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade Drupal AT Internet Piano Analytics to 2.3.1 or 1.0.1.

Affected software

ProductAffectedFixed in
DrupalAT Internet Piano AnalyticsAffected
  • <1.0.1
  • >=2.0.0 <2.3.1
Fixed in
  • 2.3.1
  • 1.0.1

AI-suggested

To mitigate CVE-2026-0947, organizations should immediately upgrade the AT Internet Piano Analytics module to versions 1.0.1 or later for the 0.x branch, and 2.3.1 or later for the 2.x branch, where the vulnerability has been addressed. If upgrading is not immediately feasible, implement strict input validation and output encoding on all user-supplied data rendered by the module, using Drupal's built-in sanitization functions such as check_plain() or Drupal's Twig auto-escaping features. Conduct a thorough audit of all custom code interacting with the module to ensure no unsafe input handling exists. Employ Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts in browsers. Monitor web server and application logs for suspicious requests that may indicate attempted exploitation. Additionally, educate web administrators and developers about secure coding practices related to XSS prevention. Regularly review and apply security updates from Drupal and module maintainers. Finally, consider deploying Web Application Firewalls (WAF) with rules targeting common XSS attack patterns as an additional protective layer.

Description

Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal AT Internet Piano Analytics allows Cross-Site Scripting (XSS).This issue affects AT Internet Piano Analytics: from 0.0.0 before 1.0.1, from 2.0.0 before 2.3.1.

References

Community reviews

Loading reviews…