Skip to main content
VulnerabilityPublished

CVE-2026-10526: EmbedPress (WordPress plugin) · Server-Side Request Forgery (SSRF)

Affects EmbedPress (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.8 Medium : upgrade to 4.6.1 when convenient.

Data as of 2 Nov 2026, 22:58 UTC

CVSS 3.1 base score
5.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.6.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade EmbedPress (WordPress plugin) to 4.6.1.

Affected software

ProductAffectedFixed in
EmbedPressAffected
  • <4.6.1
Fixed in
  • 4.6.1

AI-suggested

Until then, restricting access to the vulnerable endpoints or disabling the EmbedPress plugin may reduce risk.

Description

EmbedPress WordPress plugin versions before 4.6.1 contain a Server-Side Request Forgery (SSRF) vulnerability. This flaw allows unauthenticated attackers to make the site send HTTP requests to internal hosts and services by exploiting unauthenticated endpoints that do not validate user-supplied URLs. The vulnerability bypasses WordPress core URL validation, resulting in a blind SSRF scenario.

References

Community reviews

Loading reviews…