CVE-2026-105615: DALIBO PostgreSQL Anonymizer · Exposure of Sensitive Information Through Data Queries
Affects DALIBO PostgreSQL AnonymizerSource CVE Database V5
Not known to be exploited · CVSS 3.5 Low : upgrade to 3.3.0 when convenient.
Data as of 28 Oct 2026, 17:58 UTC
- Patch
- Available – fixed in 3.3.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade PostgreSQL Anonymizer and dalibo/postgresql_anonymizer to 3.3.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| DALIBOPostgreSQL Anonymizer | Affected
| Fixed in
|
GitHubdalibo/postgresql_anonymizerpkg:github/dalibo/postgresql_anonymizerOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to DALIBO PostgreSQL Anonymizer version 3.3.0 or later, where this vulnerability is fixed. No other mitigation is required as the fix fully addresses the issue.
Description
CVE-2026-105615 is a vulnerability in DALIBO PostgreSQL Anonymizer versions prior to 3.3.0 where optimized statistics on a table are accessible to users with SELECT privileges. This allows a masked role to infer limited sensitive information through statistical views such as histograms and most common values (MCVs). The issue is resolved in version 3.3.0 and later.