Skip to main content
VulnerabilityPublished

CVE-2026-105616: DALIBO PostgreSQL Anonymizer · Information Exposure

Affects DALIBO PostgreSQL AnonymizerSource CVE Database V5

0

Not known to be exploited · CVSS 5.7 Medium : upgrade to 3.3.0 when convenient.

Data as of 28 Oct 2026, 17:58 UTC

CVSS 3.1 base score
5.7Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.3.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade PostgreSQL Anonymizer and dalibo/postgresql_anonymizer to 3.3.0.

Affected software

ProductAffectedFixed in
DALIBOPostgreSQL AnonymizerAffected
  • >=1 <3.3.0
Fixed in
  • 3.3.0
GitHubdalibo/postgresql_anonymizerpkg:github/dalibo/postgresql_anonymizerOther threatsAffected
  • >=1 <3.3.0
Fixed in
  • 3.3.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade PostgreSQL Anonymizer to version 3.3.0 or later, where the exposure of salt and shift parameters in system catalogs is fixed.

Description

CVE-2026-105616 is a vulnerability in DALIBO PostgreSQL Anonymizer versions prior to 3.3.0 where sensitive information (salt and shift values) can be exposed to unauthorized users. Although PostgreSQL restricts access to these values via the SHOW command for non-privileged users, they remain visible in system catalogs such as pg_db_role_setting or pg_roles if set at the database or user level. This exposure could allow unauthorized actors with limited privileges to obtain sensitive anonymization parameters. The issue is fixed in PostgreSQL Anonymizer version 3.3.0 and later.

References

Community reviews

Loading reviews…