CVE-2026-106457: backstage · Improper Authentication
Affects backstageSource GCVE Database
Not known to be exploited · CVSS 6.8 Medium : upgrade to 1.55.0 when convenient.
Data as of 27 Oct 2026, 21:15 UTC
- Patch
- Available – fixed in 1.55.0
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade backstage to 1.55.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| backstage backstage | Affected
| Fixed in
|
AI-suggested
Upgrade Backstage to version 1.55.0 or later, where this improper authentication vulnerability is fixed by enforcing audience validation in the Cloudflare Access auth provider. If upgrading immediately is not possible, ensure that Cloudflare Access enforces audience restrictions upstream before requests reach the Backstage authentication endpoint to mitigate the risk.
Description
CVE-2026-106457 is an improper authentication vulnerability in the Backstage open framework affecting the @backstage/plugin-auth-backend-module-cloudflare-access-provider package versions from 1.26.0 up to but not including 1.55.0. The flaw involves insufficient audience validation in the Cloudflare Access authentication provider, allowing a valid token issued for another application within the same Cloudflare Zero Trust team to authenticate to Backstage if audience enforcement is not done upstream. This issue is fixed in version 1.55.0.