Skip to main content
VulnerabilityPublished

CVE-2026-10812: zilliztech GPTCache · Use of Weak Hash

Affects zilliztech GPTCacheSource CVE Database V5

0
Compare

Public exploit available · CVSS 2.0 Low : upgrade to 0.1.45 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
2.0Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.07% chance of exploitation in 30 days – higher than 0% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.1.45
CVSS:4.0/AV:L/AC:H/AT:N/PR:L/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade zilliztech GPTCache to 0.1.45.

Affected software

ProductAffectedFixed in
zilliztechGPTCacheAffected
  • 0.1.0 – 0.1.44
45 affected builds
Fixed in–
PyPIgptcachepkg:pypi/gptcacheOther threatsAffected
  • <0.1.45
Fixed in
  • 0.1.45

CPE configurations (1)

  • cpe:2.3:a:zilliztech:gptcache:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A pull request addressing the vulnerability is awaiting acceptance. Users should monitor the vendor's repository or advisory channels for the official patch. Until then, mitigating this vulnerability may require restricting local access to trusted users and environments to reduce the risk of exploitation.

Description

CVE-2026-10812 is a low-severity vulnerability in zilliztech GPTCache up to version 0.1.44. It involves the use of a weak hash function in the BufferedReader.peek function within the Cache Key Handler component. Exploitation requires local access and is considered highly complex and difficult. A fix has been proposed but is not yet accepted or officially released.

References

Community reviews

Loading reviews…