Skip to main content
VulnerabilityPublished

CVE-2026-108776: Apache Kylin · SQL Injection

Affects Apache KylinSource CVE Database V5

0

Not known to be exploited · fixed in 5.0.5 : update Apache Kylin when convenient.

Data as of 26 Oct 2026, 11:07 UTC

Severity
Medium

Rated Medium by the CNA (apache) · CVSS not yet scored by NVD

EPSS
0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.0.5

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software FoundationApache KylinAffected
  • >=4.0.0 <=5.0.4
Fixed in–
Mavenorg.apache.kylin/kylinpkg:maven/org.apache.kylin/kylinOther threatsAffected
  • >=4.0.0 <=5.0.4
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Kylin to version 5.0.5 or later, where this SQL Injection vulnerability has been fixed. No other mitigation actions are specified or required beyond applying the official update.

Description

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Kylin. The impact is moderate if kylin service is in query only mode, which is the default and most common mode. This issue affects Apache Kylin: from 4.0.0 through 5.0.4. Users are recommended to upgrade to version 5.0.5, which fixes the issue.

References

Community reviews

Loading reviews…