CVE-2026-64959: Apache Kylin · SQL Injection
Affects Apache KylinSource CVE Database V5
Not known to be exploited · CVSS 9.8 Critical · fixed in 5.0.5 : patch Apache Kylin as a priority.
Data as of 26 Oct 2026, 11:20 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 35% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.0.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 16 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Kylin | Affected
| Fixed in– |
Mavenorg.apache.kylin/kylinpkg:maven/org.apache.kylin/kylinOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache Kylin to version 5.0.5, which contains the official fix for this vulnerability. No other mitigations are indicated by the vendor advisory. Since this affects backend cache APIs missing authentication, restricting network exposure of Kylin services to trusted environments can reduce risk until upgrade is applied.
Description
Apache Kylin versions 5.0.0 through 5.0.4 contain a critical SQL Injection vulnerability due to improper neutralization of special elements in SQL commands and missing authentication for a critical backend cache API. This flaw allows unauthenticated attackers to execute injected SQL commands, potentially compromising confidentiality, integrity, and availability. The issue primarily affects Kylin services exposed directly to public networks, which is uncommon in typical in-house deployments. Upgrading to version 5.0.5 resolves the vulnerability.