Skip to main content
VulnerabilityPublished Updated

CVE-2026-109266: ImageMagick · Cross-site Scripting

Affects ImageMagickSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.9 Medium : upgrade to 7.1.2-32 when convenient.

Data as of 29 Oct 2026, 21:45 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.06.9
CNA (VulnCheck)CVSS 3.15.3
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers can reliably automate steps 1–4 of the kill chain
Technical impact
Limited control over the software or limited information exposure

CISA SSVC assessment, 2026-10-18.

Patch
Available – fixed in 7.1.2-32, 6.9.13-57
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade ImageMagick to 7.1.2-32; ImageMagick to 6.9.13-57.

Affected software

ProductAffectedFixed in
ImageMagickImageMagickAffected
  • >=7.0.0-0 <7.1.2-32
Fixed in
  • 7.1.2-32
ImageMagickImageMagickAffected
  • <6.9.13-57
Fixed in
  • 6.9.13-57

AI-suggested

Users should upgrade ImageMagick to version 6.9.13-57 or later in the 6.x series, or 7.1.2-32 or later in the 7.x series to remediate this vulnerability. No other mitigation or workaround is indicated. Since this is a software vulnerability, applying the official vendor fix is the recommended action.

Description

ImageMagick before 6.9.13-57 and 7.x before 7.1.2-32 contains an XML injection vulnerability in the CIP encoder, which does not properly escape input-derived data when writing Cisco IP Phone XML output. Attackers can supply a crafted file that, when converted to CIP format, injects arbitrary markup into the generated XML.

References

Community reviews

Loading reviews…