Skip to main content
VulnerabilityPublished Updated

CVE-2026-109267: ImageMagick · Uncontrolled Recursion

Affects ImageMagickSource GCVE Database

0
Compare

Not known to be exploited · CVSS 6.9 Medium : upgrade to 7.1.2-32 or 6.9.13-57 when convenient.

Data as of 3 Nov 2026, 18:13 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.06.9
CNA (VulnCheck)CVSS 3.15.3
Patch
Available – fixed in 7.1.2-32, 6.9.13-57
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade ImageMagick to 7.1.2-32 or 6.9.13-57.

Affected software

ProductAffectedFixed in
ImageMagick ImageMagickAffected
  • <6.9.13-57
  • <7.1.2-32
Fixed in
  • 6.9.13-57
  • 7.1.2-32

AI-suggested

A fix is available in ImageMagick versions 6.9.13-57 and 7.1.2-32 and later. Users should upgrade to these or newer versions to remediate this vulnerability. No additional mitigations are indicated.

Description

ImageMagick versions before 6.9.13-57 and 7.x before 7.1.2-32 have a stack overflow vulnerability in the MSL decoder due to an incorrect depth check that allows uncontrolled recursion. This flaw can be triggered by specially crafted MSL images, causing the process to crash and resulting in a denial of service.

References

Community reviews

Loading reviews…