CVE-2026-109346: better-auth · User Interface (UI) Misrepresentation of Critical Information
Affects better-authSource CVE Database V5
Not known to be exploited · CVSS 8.5 High : upgrade to 1.7.0-rc.3 soon.
Data as of 26 Oct 2026, 17:30 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- CISA SSVC
- Exploitation
- No evidence of active exploitation and no public proof of concept
- Automatable
- Attackers cannot reliably automate steps 1–4 of the kill chain
- Technical impact
- Total control over the software or total information disclosure
CISA SSVC assessment, 2026-10-26.
- Patch
- Available – fixed in 1.7.0-rc.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 12 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade better-auth to 1.7.0-rc.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| better-authbetter-auth | Affected
| Fixed in
|
npmbetter-authpkg:npm/better-authOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade better-auth to version 1.7.0-rc.3 or later, where this vulnerability is fixed. No additional mitigation is required once the patch is applied.
Description
CVE-2026-109346 is a high-severity vulnerability in better-auth versions from 1.3.8-beta.3 up to but not including 1.7.0-rc.3. It involves a user interface misrepresentation in the deviceAuthorization plugin where the GET /device endpoint omits critical information such as the client_id and scope. This omission allows attackers to initiate a device authorization request, trick signed-in users into approving it, and then redeem the authorization code to obtain a live session token. The issue is fixed in version 1.7.0-rc.3.