Skip to main content
VulnerabilityPublished

CVE-2026-109821: elixir · Improper Validation of Specified Quantity in Input

Affects elixirSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.3 Medium · fixed in 1.20.5 : update elixir when convenient.

Data as of 30 Oct 2026, 12:04 UTC

CVSS 4.0 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (EEF)CVSS 4.06.3
Patch
Available – fixed in 1.20.5, 1.19.7, 1.18.6
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade elixir to 1.20.5, 1.19.7 or 1.18.6.

Affected software

ProductAffectedFixed in
elixir-langelixirAffected
  • >=1.20.0-rc.0 <1.20.5
Fixed in
  • 1.20.5
elixir-langelixirAffected
  • >=1.19.0-rc.0 <1.19.7
Fixed in
  • 1.19.7
elixir-langelixirAffected
  • >=0.5.0 <1.18.6
Fixed in
  • 1.18.6
elixirelixir-lang/elixirAffected
  • ≥ 39801821eef2d06524e5ebf5a0e4b3c380ad23ae, < 9a39d64a4473d02681c486bc70681c972479d32b
Fixed in–
GitHubelixirpkg:github/elixirOther threatsAffected
  • >=0.5.0 <1.18.6
  • >=1.19.0-rc.0 <1.19.7
  • >=1.20.0-rc.0 <1.20.5
Fixed in
  • 1.18.6
  • 1.19.7
  • 1.20.5

CPE configurations (1)

  • cpe:2.3:a:elixir-lang:elixir:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Fixed versions of Elixir are 1.18.6, 1.19.7, and 1.20.5. Users should upgrade to these or later versions to remediate the vulnerability. No other mitigations or workarounds are specified. The vulnerability is not present in versions at or beyond these fixed releases.

Description

CVE-2026-109821 is a vulnerability in the Elixir standard library's URI module where improper validation of the port component in a URL can lead to denial of service via CPU exhaustion. The URI.parse/1 function converts the port string to an integer without limiting its length, allowing extremely large port numbers to be processed. Rendering such a URI back to text triggers a quadratic-time conversion in Erlang/OTP versions 27, 28, and 29.0, causing significant CPU load and delays. This affects Elixir versions from 0.5.0 up to but not including 1.18.6, from 1.19.0-rc.0 up to but not including 1.19.7, and from 1.20.0-rc.0 up to but not including 1.20.5.

References

Community reviews

Loading reviews…