Skip to main content
VulnerabilityPublished

CVE-2026-115274: elixir · Improper Validation of Specified Quantity in Input

Affects elixirSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.9 Medium · fixed in 1.20.5 : update elixir when convenient.

Data as of 30 Oct 2026, 12:04 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (EEF)CVSS 4.06.9
Patch
Available – fixed in 1.20.5, 1.19.7, 1.18.6
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade elixir to 1.20.5, 1.19.7 or 1.18.6.

Affected software

ProductAffectedFixed in
elixir-langelixirAffected
  • >=1.20.0-rc.0 <1.20.5
Fixed in
  • 1.20.5
elixir-langelixirAffected
  • >=1.19.0-rc.0 <1.19.7
Fixed in
  • 1.19.7
elixir-langelixirAffected
  • >=1.18.0-rc.0 <1.18.6
Fixed in
  • 1.18.6
elixirelixir-lang/elixirAffected
  • ≥ 793c1147210388587defb649f25f293ffbfa6b1b, < c81f12265919c34a0d5134f1905a4eb4edaea1c2
Fixed in–
GitHubelixirpkg:github/elixirOther threatsAffected
  • >=1.18.0-rc.0 <1.18.6
  • >=1.19.0-rc.0 <1.19.7
  • >=1.20.0-rc.0 <1.20.5
Fixed in
  • 1.18.6
  • 1.19.7
  • 1.20.5

CPE configurations (1)

  • cpe:2.3:a:elixir-lang:elixir:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Elixir to version 1.18.6, 1.19.7, or 1.20.5 or later, where this vulnerability is fixed. No other mitigation or workaround is indicated in the vendor advisory.

Description

CVE-2026-115274 is a vulnerability in the Elixir standard library's JSON module where improper validation of integer literal length in JSON input can lead to denial of service via CPU and memory exhaustion. The functions JSON.decode/1 and JSON.decode!/1 convert integer literals without bounding their length, allowing extremely large integers to consume excessive resources. This affects Elixir versions from 1.18.0-rc.0 before 1.18.6, from 1.19.0-rc.0 before 1.19.7, and from 1.20.0-rc.0 before 1.20.5. Fixed versions are 1.18.6, 1.19.7, and 1.20.5.

References

Community reviews

Loading reviews…