Skip to main content
VulnerabilityPublished

CVE-2026-110935: Phoenix Contact PLCnext Engineer · Path Traversal

Affects Phoenix Contact PLCnext EngineerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.6 High : upgrade to 2026.6 soon.

Data as of 4 Nov 2026, 09:43 UTC

CVSS 4.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (CERTVDE)CVSS 4.08.6
CNA (CERTVDE)CVSS 3.18.4
Patch
Available – fixed in 2026.6
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade Phoenix Contact PLCnext Engineer to 2026.6.

Affected software

ProductAffectedFixed in
Phoenix ContactPLCnext EngineerAffected
  • <2026.6
Fixed in
  • 2026.6

AI-suggested

A fix for this vulnerability is available in Phoenix Contact PLCnext Engineer version 2026.6. Users should upgrade to this version to remediate the issue. No additional mitigation steps are indicated by the vendor advisory.

Description

CVE-2026-110935 is a path traversal vulnerability in the PFI plugin framework deployment routine of Phoenix Contact PLCnext Engineer. The vulnerability arises because the deployment process does not properly validate path components when extracting archive entries, allowing relative path segments like '..'. This flaw permits an unauthenticated local attacker to write files outside the intended plugin repository to arbitrary locations accessible by the current user's permissions, potentially leading to full system compromise. The issue affects versions prior to 2026.6 and has a high severity rating with a CVSS score of 8.6. A fix is available in version 2026.6.

References

Community reviews

Loading reviews…