CVE-2026-110022: Phoenix Contact PLCnext Engineer · Download of Code Without Integrity Check
Affects Phoenix Contact PLCnext EngineerSource CVE Database V5
Not known to be exploited · CVSS 8.6 High : upgrade to 2026.6 soon.
Data as of 4 Nov 2026, 09:43 UTC
Thin evidence
One scorer or none| CNA (CERTVDE) | CVSS 4.0 | 8.6 |
|---|---|---|
| CNA (CERTVDE) | CVSS 3.1 | 8.4 |
- Patch
- Available – fixed in 2026.6
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 4 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade Phoenix Contact PLCnext Engineer to 2026.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Phoenix ContactPLCnext Engineer | Affected
| Fixed in
|
AI-suggested
A fix for this vulnerability is available in Phoenix Contact PLCnext Engineer version 2026.6. Users should upgrade to this version or later to remediate the issue. No additional mitigations are specified by the vendor advisory.
Description
CVE-2026-110022 is a high-severity vulnerability in Phoenix Contact PLCnext Engineer affecting versions prior to 2026.6. The vulnerability arises because the PFI plugin framework deploys DLLs from signed plugin packages but fails to verify the integrity of all archive entries. An unauthenticated local attacker can replace an unsigned DLL outside the signed prefix in the archive, which passes signature verification and overwrites a legitimate signed assembly. This leads to the plugin loader instantiating attacker-supplied code without further integrity checks, resulting in full system compromise.