CVE-2026-111089: Apache Wicket · Cross-site Scripting
Affects Apache WicketSource CVE Database V5
Not known to be exploited · CVSS 7.6 High.
Data as of 1 Nov 2026, 22:58 UTC
Thin evidence
One scorer or none| CNA (apache) | CVSS 4.0 | 7.6 |
|---|
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 1 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Wicketorg.apache.wicket:wicket-core | Affected
| Fixed in– |
Mavenorg.apache.wicket/wicket-corepkg:maven/org.apache.wicket/wicket-coreOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache Wicket to versions 8.20.0, 9.25.0, or 10.12.0, which contain fixes for this vulnerability. No other mitigations are indicated as the vendor recommends upgrading to these fixed versions. There is no mention of temporary workarounds or configuration changes that fully mitigate the issue.
Description
CVE-2026-111089 is a cross-site scripting (XSS) vulnerability in Apache Wicket versions 8.0.0 through 8.19.0, 9.0.0 through 9.24.0, and 10.0.0 through 10.11.0. The issue arises because texts from resource bundles are inserted into JavaScript string literals and HTML attribute values without proper escaping, allowing injection of malicious script if the text contains quotes or is controlled by an attacker. The default Content-Security-Policy in Wicket 9.x and 10.x does not prevent exploitation of the JavaScript injection vectors. Fixed versions are 8.20.0, 9.25.0, and 10.12.0.