CVE-2026-83539: Apache Wicket · Cross-site Scripting
Affects Apache WicketSource CVE Database V5
Not known to be exploited · CVSS 7.4 High.
Data as of 1 Nov 2026, 22:43 UTC
Thin evidence
One scorer or none| CNA (apache) | CVSS 4.0 | 7.4 |
|---|
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 1 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Wicketorg.apache.wicket:wicket-extensions | Affected
| Fixed in– |
Mavenorg.apache.wicket/wicket-extensionspkg:maven/org.apache.wicket/wicket-extensionsOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache Wicket to versions 8.20.0, 9.25.0, or 10.12.0 where this vulnerability is fixed. Applications using Wicket 9.x and 10.x should ensure that the default Content-Security-Policy is enabled and not weakened or disabled, as it provides effective mitigation. For Wicket 8.x users, upgrading is strongly recommended since no CSP protection is present. No other configuration changes or workarounds are indicated.
Description
CVE-2026-83539 is a cross-site scripting (XSS) vulnerability in Apache Wicket's SmartLinkLabel and SmartLinkMultiLineLabel components. These components convert URLs found in text into clickable links without restricting URL schemes, allowing potentially malicious script execution when a user activates such a link. The vulnerability affects Apache Wicket versions 8.0.0 through 8.19.0, 9.0.0 through 9.24.0, and 10.0.0 through 10.11.0. Default Content-Security-Policy (CSP) in versions 9.x and 10.x mitigates this risk by restricting script execution, but applications that weaken or disable CSP are fully vulnerable. Version 8.x lacks CSP support and is fully affected. Fixed versions are 8.20.0, 9.25.0, and 10.12.0.