Skip to main content
VulnerabilityPublished

CVE-2026-95863: Apache Wicket · Cross-site Scripting

Affects Apache WicketSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.6 High · fixed in 8.20.0 : patch Apache Wicket soon.

Data as of 1 Nov 2026, 22:58 UTC

CVSS 4.0 base score
7.6High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (apache)CVSS 4.07.6
Patch
Available – fixed in 8.20.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Wicketorg.apache.wicket:wicket-coreAffected
  • >=8.0.0 <=8.19.0
  • >=9.0.0 <=9.24.0
  • >=10.0.0 <=10.11.0
Fixed in–
Mavenorg.apache.wicket/wicket-corepkg:maven/org.apache.wicket/wicket-coreOther threatsAffected
  • >=8.0.0 <=8.19.0
  • >=9.0.0 <=9.24.0
  • >=10.0.0 <=10.11.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Wicket to versions 8.20.0, 9.25.0, or 10.12.0 or later, where the issue is fixed by validating and rejecting unsafe characters in component and markup IDs. No other mitigation is recommended since the fix prevents unsafe IDs from being used and the default Content-Security-Policy does not block the injected script. Applications should avoid setting component or markup IDs containing special characters.

Description

CVE-2026-95863 is a cross-site scripting (XSS) vulnerability in Apache Wicket versions 8.0.0 through 8.19.0, 9.0.0 through 9.24.0, and 10.0.0 through 10.11.0. The flaw arises because Apache Wicket improperly escapes component markup IDs and input names when embedding them into JavaScript string literals, allowing injection of malicious script code if these IDs contain special characters such as quotes or backslashes. The vulnerability is fixed in versions 8.20.0, 9.25.0, and 10.12.0 by validating and rejecting unsafe characters in IDs at entry rather than escaping them in multiple places.

References

Community reviews

Loading reviews…