CVE-2026-111959: Apache Arrow Rust · Out-of-bounds Read
Affects Apache Arrow RustSource CVE Database V5
Not known to be exploited : upgrade to 60.1.0 soon.
Data as of 2 Nov 2026, 13:58 UTC
Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD
Thin evidence
One scorer or none- Patch
- Available – fixed in 60.1.0
Exploitation evidence
Disclosed: evidence found.
CVE published 2 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Upgrade Apache Arrow Rust and arrow to 60.1.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Arrow Rustarrow | Affected
| Fixed in
|
crates.ioarrowpkg:cargo/arrowOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade affected Apache Arrow Rust versions to 60.1.0, 59.3.2, 58.4.1, or 57.3.2 where the vulnerability is fixed. No other mitigation or temporary workaround is indicated.
Description
An out-of-bounds read vulnerability exists in Apache Arrow Rust's ArrayData interface due to improper validation of RunEndEncoded arrays. This flaw affects versions from 33.0.0 through 57.3.1, 58.4.0, 59.3.1, and 60.0.0. The issue is fixed in version 60.1.0 and other specified patch releases.