CVE-2026-113369: Sonatype Nexus Repository 3 · Cross-site Scripting
Affects Sonatype Nexus Repository 3Source CVE Database V5
Not known to be exploited · CVSS 6.3 Medium : upgrade to 3.98.0 when convenient.
Data as of 4 Nov 2026, 20:51 UTC
Thin evidence
One scorer or none| CNA (Sonatype) | CVSS 4.0 | 6.3 |
|---|
- Patch
- Available – fixed in 3.98.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 4 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade Sonatype Nexus Repository 3 to 3.98.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| SonatypeNexus Repository 3 | Affected
| Fixed in
|
CPE configurations (15)
cpe:2.3:a:sonatype:nexus_repository_manager:3.94.0:*:*:*:*:*:*:*cpe:2.3:a:sonatype:nexus_repository_manager:3.94.1:*:*:*:*:*:*:*cpe:2.3:a:sonatype:nexus_repository_manager:3.94.2:*:*:*:*:*:*:*cpe:2.3:a:sonatype:nexus_repository_manager:3.95.0:*:*:*:*:*:*:*cpe:2.3:a:sonatype:nexus_repository_manager:3.95.1:*:*:*:*:*:*:*cpe:2.3:a:sonatype:nexus_repository_manager:3.95.2:*:*:*:*:*:*:*
AI-suggested
Upgrade Sonatype Nexus Repository 3 to version 3.98.0 or later, where this vulnerability is fixed. No other mitigation or workaround is indicated by the vendor advisory.
Description
CVE-2026-113369 is a cross-site scripting (XSS) vulnerability in Sonatype Nexus Repository 3. It affects versions from 3.94.0 up to but not including 3.98.0. A user with edit permissions on a hosted OCI repository can inject script content into the artifact type field of an OCI manifest. This script executes in the browser of any user who views the Attestations tab for the related image, running with the permissions of the viewing user. The vulnerability has a medium severity with a CVSS 4.0 score of 6.3. It was fixed in version 3.98.0.