CVE-2026-17596: Sonatype Nexus Repository 3 · Cross-site Scripting
Affects Sonatype Nexus Repository 3Source CVE Database V5
Not known to be exploited · CVSS 6.3 Medium : upgrade to 3.95.0 when convenient.
Data as of 5 Nov 2026, 23:24 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.95.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 7 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade Nexus Repository 3 and sonatype/nexus_repository_manager to 3.95.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| SonatypeNexus Repository 3 | Affected
| Fixed in
|
Mavensonatype/nexus_repository_managerpkg:maven/sonatype/nexus_repository_managerOther threats | Affected
| Fixed in
|
CPE configurations (150)
cpe:2.3:a:sonatype:nexus_repository_manager:3.16.0:*:*:*:*:*:*:*cpe:2.3:a:sonatype:nexus_repository_manager:3.16.1:*:*:*:*:*:*:*cpe:2.3:a:sonatype:nexus_repository_manager:3.16.2:*:*:*:*:*:*:*cpe:2.3:a:sonatype:nexus_repository_manager:3.17.0:*:*:*:*:*:*:*cpe:2.3:a:sonatype:nexus_repository_manager:3.17.1:*:*:*:*:*:*:*cpe:2.3:a:sonatype:nexus_repository_manager:3.17.2:*:*:*:*:*:*:*
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Sonatype Nexus Repository 3 to version 3.95.0 or later, where this vulnerability is fixed. No other official remediation or temporary workaround is indicated. Users should ensure that only trusted users have nexus:blobstores:create or nexus:blobstores:update permissions to reduce risk until patched.
Description
Nexus Repository 3 was found to be vulnerable to stored cross-site scripting (XSS). A user with the nexus:blobstores:create or nexus:blobstores:update permission could set a blob store name containing malicious script content, which would later execute in the browser of another user viewing system health-check status. This issue has been fixed in version 3.95.0.