CVE-2026-113373: Sonatype Nexus Repository 3 · Weak Authentication
Affects Sonatype Nexus Repository 3Source CVE Database V5
Not known to be exploited · CVSS 9.1 Critical : upgrade to 3.98.0 as a priority.
Data as of 4 Nov 2026, 21:42 UTC
Thin evidence
One scorer or none| CNA (Sonatype) | CVSS 4.0 | 9.1 |
|---|
- Patch
- Available – fixed in 3.98.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 4 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade Sonatype Nexus Repository 3 to 3.98.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| SonatypeNexus Repository 3 | Affected
| Fixed in
|
CPE configurations (41)
cpe:2.3:a:sonatype:nexus_repository_manager:3.86.0:*:*:*:*:*:*:*cpe:2.3:a:sonatype:nexus_repository_manager:3.86.1:*:*:*:*:*:*:*cpe:2.3:a:sonatype:nexus_repository_manager:3.86.2:*:*:*:*:*:*:*cpe:2.3:a:sonatype:nexus_repository_manager:3.86.3:*:*:*:*:*:*:*cpe:2.3:a:sonatype:nexus_repository_manager:3.87.0:*:*:*:*:*:*:*cpe:2.3:a:sonatype:nexus_repository_manager:3.87.1:*:*:*:*:*:*:*
AI-suggested
Upgrade Sonatype Nexus Repository 3 Pro to version 3.98.0 or later, where this vulnerability is fixed. Until the upgrade is applied, administrators should consider additional controls on identity provider accounts or restrict access to the Nexus Repository service. No other vendor advisories indicate alternative mitigations or that the issue is already mitigated.
Description
Sonatype Nexus Repository 3 Pro versions from 3.86.0 up to but not including 3.98.0 contain a critical authentication vulnerability. The product does not verify the local account status when users authenticate via configured SAML or OAuth2/OpenID Connect identity providers. This allows users whose Nexus accounts have been disabled or locked by an administrator to sign in again using valid identity provider credentials and regain access with their original roles. The vulnerability requires a valid identity provider account and does not affect anonymous users.