CVE-2026-114707: JetElements For Elementor (WordPress plugin) · Cross-site Scripting
Affects JetElements For Elementor (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 6.5 Medium : upgrade to 2.9.2.6 when convenient.
Data as of 26 Oct 2026, 14:18 UTC
- Patch
- Available – fixed in 2.9.2.6
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 26 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade JetElements For Elementor (WordPress plugin) to 2.9.2.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| JetElements For Elementorjet-elements | Affected
| Fixed in
|
AI-suggested
Upgrade JetElements For Elementor to version 2.9.2.6 or later to remediate this vulnerability. No other specific mitigations are indicated by the vendor advisory.
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Crocoblock JetElements For Elementor jet-elements allows Stored XSS.This issue affects JetElements For Elementor: from n/a through 2.9.2.5.