CVE-2026-24958: JetElements For Elementor (WordPress plugin) · Cross-site Scripting
Affects JetElements For Elementor (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 6.5 Medium : upgrade to 2.7.12.3 when convenient.
Data as of 26 Oct 2026, 08:30 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.7.12.3
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 3 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade JetElements For Elementor (WordPress plugin) to 2.7.12.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| CrocoblockJetElements For Elementor | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, consider limiting exposure by restricting user input where possible and applying web application firewall (WAF) rules to detect and block XSS attempts specific to this component.
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Crocoblock JetElements For Elementor jet-elements allows DOM-Based XSS.This issue affects JetElements For Elementor: from n/a through <= 2.7.12.2.