CVE-2026-116572: signalwire freeswitch · Stack-based Buffer Overflow
Affects signalwire freeswitchSource CVE Database V5
Not known to be exploited · CVSS 6.5 Medium : upgrade to 1.11.2 when convenient.
Data as of 5 Nov 2026, 20:03 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 6.5 |
|---|
- Patch
- Available – fixed in 1.11.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 5 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade signalwire freeswitch to 1.11.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| signalwirefreeswitch | Affected
| Fixed in
|
AI-suggested
Upgrade FreeSWITCH to version 1.11.2 or later, where this vulnerability is fixed. Until the upgrade is applied, ensure that subscription authentication is enabled to reduce the risk of exploitation. Presence management features should be carefully controlled or disabled if not needed to limit exposure.
Description
FreeSWITCH versions from 1.10.0 up to 1.11.1 contain a stack-based buffer overflow vulnerability in the mod_sofia module when processing SIP Contact display names for dialog-event notifications. An attacker can exploit this by establishing a dialog with an excessively long display name and subscribing to dialog events, causing a buffer overflow that can crash the FreeSWITCH process and disrupt active calls. Exploitation requires presence management to be enabled and typically valid profile credentials unless subscription authentication is disabled. This vulnerability is fixed in version 1.11.2.