Skip to main content
VulnerabilityPublished

CVE-2026-116590: xerial snappy-java · Improper Validation of Array Index

Affects xerial snappy-javaSource CVE Database V5

0

Not known to be exploited · CVSS 5.9 Medium : upgrade to 1.1.10.9 when convenient.

Data as of 26 Oct 2026, 22:12 UTC

CVSS 3.1 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.1.10.9
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade snappy-java and org.xerial/snappy-java to 1.1.10.9.

Affected software

ProductAffectedFixed in
xerialsnappy-javaAffected
  • <1.1.10.9
Fixed in
  • 1.1.10.9
Mavenorg.xerial/snappy-javapkg:maven/org.xerial/snappy-javaOther threatsAffected
  • <1.1.10.9
Fixed in
  • 1.1.10.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to snappy-java version 1.1.10.9 or later, where this vulnerability is fixed. No other mitigations are indicated or required.

Description

CVE-2026-116590 is a vulnerability in the xerial snappy-java library prior to version 1.1.10.9. It involves improper validation of array indices in the Snappy.arrayCopy method, which allows passing negative or oversized offset and byteLength values to native memcpy calls. This can cause out-of-bounds reads or writes, potentially crashing the Java Virtual Machine (JVM). The issue affects methods like SnappyOutputStream.rawWrite and SnappyInputStream.rawRead that use this primitive. The vulnerability is fixed in version 1.1.10.9.

References

Community reviews

Loading reviews…