Skip to main content
VulnerabilityPublished

CVE-2026-116688: ckeditor ckeditor5 · Cross-site Scripting

Affects ckeditor ckeditor5Source CVE Database V5

0

Not known to be exploited · CVSS 8.1 High : upgrade to 48.5.1 or 47.7.4 soon.

Data as of 27 Oct 2026, 19:57 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 48.5.1, 47.7.4
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade ckeditor ckeditor5 to 48.5.1 or 47.7.4.

Affected software

ProductAffectedFixed in
ckeditorckeditor5Affected
  • >=48.0.0 <48.5.1
Fixed in
  • 48.5.1
ckeditorckeditor5Affected
  • >=45.0.0 <47.7.4
Fixed in
  • 47.7.4

AI-suggested

Upgrade CKEditor 5 to version 47.7.4 or later, or to version 48.5.1 or later, where the vulnerability is fixed. No other mitigation is indicated by the vendor advisory.

Description

CKEditor 5 versions from 45.0.0 up to but not including 47.7.4, and from 48.0.0 up to but not including 48.5.1, contain a cross-site scripting (XSS) vulnerability due to prototype pollution in a vulnerable es-toolkit version used by the editor engine. This flaw allows crafted editor content to execute unauthorized JavaScript in the browser. The issue is resolved in versions 47.7.4 and 48.5.1.

References

Community reviews

Loading reviews…