Skip to main content
VulnerabilityPublished Updated

CVE-2026-28343: ckeditor ckeditor5 · Cross-site Scripting

Affects ckeditor ckeditor5Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.4 Medium : upgrade to 47.6.0 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
6.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 47.6.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade ckeditor ckeditor5 to 47.6.0.

Affected software

ProductAffectedFixed in
ckeditorckeditor5Affected
  • >=29.0.0 <47.6.0
Fixed in
  • 47.6.0

AI-suggested

To mitigate CVE-2026-28343, organizations should immediately upgrade CKEditor 5 to version 47.6.0 or later, where the vulnerability is patched. If upgrading is not immediately feasible, administrators should review and harden the General HTML Support configuration to restrict or disable unsafe markup inputs, ensuring strict input validation and sanitization are enforced. Implement Content Security Policy (CSP) headers to limit the impact of potential script injection by restricting script sources and execution contexts. Web application firewalls (WAFs) can be tuned to detect and block suspicious markup patterns targeting CKEditor instances. Regularly audit and monitor logs for unusual editor activity or injection attempts. Educate developers and administrators on secure configuration practices for rich-text editors and conduct security testing focused on XSS vectors in web content management components. Finally, maintain an up-to-date inventory of CKEditor versions deployed across environments to ensure timely patch management.

Description

CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. Starting in version 29.0.0 and prior to version 47.6.0, a cross-site scripting (XSS) vulnerability has been discovered in the General HTML Support feature. This vulnerability could be triggered by inserting specially crafted markup, leading to unauthorized JavaScript code execution, if the editor instance used an unsafe General HTML Support configuration. This issue has been patched in version 47.6.0.

References

Community reviews

Loading reviews…