Skip to main content
VulnerabilityPublished

CVE-2026-116843: mistralai mistral-vibe · Untrusted Functionality Inclusion

Affects mistralai mistral-vibeSource CVE Database V5

0

Not known to be exploited · CVSS 8.7 High : upgrade to 3.0.3 soon.

Data as of 27 Oct 2026, 01:27 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.0.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade mistralai mistral-vibe to 3.0.3.

Affected software

ProductAffectedFixed in
mistralaimistral-vibeAffected
  • <3.0.3
Fixed in
  • 3.0.3
PyPImistral-vibepkg:pypi/mistral-vibeOther threatsAffected
  • <3.0.3
Fixed in
  • 3.0.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Mistral Vibe to version 3.0.3 or later, where this vulnerability is fixed. No other mitigation is indicated by the vendor advisory. Users should avoid using untrusted repositories with the --worktree option until patched.

Description

Mistral Vibe versions before 3.0.3 have a remote code execution vulnerability. This flaw allows attackers to execute arbitrary commands by defining git filter drivers in an untrusted repository's .git/config file. When the application is started with the --worktree option, git worktree add applies .gitattributes and runs filter commands before verifying the trusted folder, leading to execution of attacker-controlled commands with user privileges. The vulnerability is fixed in version 3.0.3.

References

Community reviews

Loading reviews…