CVE-2026-117518: @fastify/reply-from · Path Traversal
Affects @fastify/reply-fromSource CVE Database V5
Not known to be exploited · CVSS 8.2 High : upgrade to 12.8.1 soon.
Data as of 2 Nov 2026, 11:12 UTC
Thin evidence
One scorer or none| CNA (openjs) | CVSS 3.1 | 8.2 |
|---|
- Patch
- Available – fixed in 12.8.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 2 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Upgrade @fastify/reply-from to 12.8.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| @fastify/reply-from@fastify/reply-from | Affected
| Fixed in
|
npm@fastify/reply-frompkg:npm/@fastify/reply-fromOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade @fastify/reply-from to version 12.8.1 or later. There are no alternative workarounds; patching is required to address the vulnerability.
Description
@fastify/reply-from versions up to 12.8.0 contain a path traversal vulnerability due to improper validation of backslash dot-segments in proxy paths. This allows unauthenticated requests to bypass intended upstream path restrictions and access unintended resources. The vulnerability is fixed in version 12.8.1 by normalizing paths and rejecting unsafe segments before URL construction.