CVE-2026-120214: @fastify/http-proxy · Path Traversal
Affects @fastify/http-proxySource CVE Database V5
Not known to be exploited · CVSS 5.9 Medium : upgrade to 11.6.3 when convenient.
Data as of 2 Nov 2026, 11:12 UTC
Thin evidence
One scorer or none| CNA (openjs) | CVSS 3.1 | 5.9 |
|---|
- Patch
- Available – fixed in 11.6.3
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 2 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Upgrade @fastify/http-proxy to 11.6.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| @fastify/http-proxy@fastify/http-proxy | Affected
| Fixed in
|
npm@fastify/http-proxypkg:npm/@fastify/http-proxyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade @fastify/http-proxy to version 11.6.3 or later, where the vulnerability is fixed. No other mitigation is required as the fix addresses the root cause in the destination validation logic.
Description
@fastify/http-proxy versions 11.6.0 through 11.6.2 contain a path traversal vulnerability due to improper normalization of backslashes before percent-decoding the request path. This allows an unauthenticated remote attacker to access resources outside the intended proxy prefix on upstream servers that treat backslashes as path separators. The vulnerability impacts confidentiality but not integrity or availability. The issue is fixed in version 11.6.3.