Skip to main content
VulnerabilityPublished

CVE-2026-120213: @fastify/http-proxy · Path Traversal

Affects @fastify/http-proxySource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.1 Critical : upgrade to 11.6.6 as a priority.

Data as of 2 Nov 2026, 11:12 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (openjs)CVSS 3.19.1
Patch
Available – fixed in 11.6.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade @fastify/http-proxy to 11.6.6.

Affected software

ProductAffectedFixed in
@fastify/http-proxy@fastify/http-proxyAffected
  • >=9.0.0 <11.6.6
Fixed in
  • 11.6.6
npm@fastify/http-proxypkg:npm/@fastify/http-proxyOther threatsAffected
  • >=9.0.0 <11.6.6
Fixed in
  • 11.6.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade @fastify/http-proxy to version 11.6.6 or later to remediate this vulnerability. There is no known workaround other than upgrading.

Description

@fastify/http-proxy versions 9.0.0 through 11.6.5 contain a path traversal vulnerability due to improper handling of URL-decoded route parameters in the rewritePrefix option. This allows an unauthenticated attacker to bypass path restrictions and potentially perform server-side request forgery or authorization bypass on the upstream service. The issue is fixed in version 11.6.6, and upgrading is required as no other workaround exists.

References

Community reviews

Loading reviews…