CVE-2026-118173: misp-guard · Improper Input Validation
Affects misp-guardSource CVE Database V5
Not known to be exploited · CVSS 6.1 Medium : upgrade to 1.4 when convenient.
Data as of 27 Oct 2026, 18:42 UTC
- Patch
- Available – fixed in 1.4
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:N/VA:N/SC:N/SI:H/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 27 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade misp-guard to 1.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| MISPmisp-guard | Affected
| Fixed in
|
GitHubmisp-guardpkg:github/misp-guardOther threats | Affected
| Fixed in
|
CPE configurations (1)
cpe:2.3:a:misp:misp-guard:*:*:*:*:*:*:*:*
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade MISP Guard to version 1.4 or later, where the input validation logic for required taxonomy tags has been corrected to ensure all tags are verified against the allowed list. No other mitigation is required as the vulnerability is fixed in this official release.
Description
MISP Guard, a proxy enforcing security policies on MISP feed data, had an incomplete input validation flaw in its handling of required taxonomy tags. The guard verified only that at least one tag from a required taxonomy was allowed but failed to ensure all tags from that taxonomy were permitted. This allowed events or attributes to carry both allowed and non-allowed tags simultaneously, bypassing data classification restrictions and potentially exposing sensitive data to unauthorized feed consumers. The vulnerability affected event-level and attribute-level validations, including nested and shadow attributes. It was fixed in version 1.4.