Skip to main content
VulnerabilityPublished

CVE-2026-118266: labstack echo · Cross-Site Request Forgery (CSRF)

Affects labstack echoSource CVE Database V5

0

Not known to be exploited · CVSS 5.3 Medium : upgrade to 5.4.0 or 4.16.0 when convenient.

Data as of 28 Oct 2026, 20:45 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.4.0, 4.16.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade labstack echo to 5.4.0 or 4.16.0.

Affected software

ProductAffectedFixed in
labstackechoAffected
  • >=5.0.0 <5.4.0
Fixed in
  • 5.4.0
labstackechoAffected
  • <4.16.0
Fixed in
  • 4.16.0

AI-suggested

Upgrade Echo to version 4.16.0 or later in the 4.x series, or to version 5.4.0 or later in the 5.x series, where this vulnerability is fixed. Ensure that the MethodOverride middleware is registered after the CSRF middleware in the middleware chain if upgrading is not immediately possible.

Description

A Cross-Site Request Forgery (CSRF) vulnerability exists in the labstack Echo Go web framework prior to versions 4.16.0 and 5.4.0. The issue arises when the MethodOverride middleware is registered before the CSRF middleware in the post-routing chain, allowing an attacker to bypass CSRF token validation and Sec-Fetch-Site checks by overriding the HTTP method of a POST request. This can lead to unauthorized state-changing actions if the victim is authenticated and the override value is controllable via a browser-submitted request. The vulnerability is fixed in versions 4.16.0 and 5.4.0.

References

Community reviews

Loading reviews…