Skip to main content
VulnerabilityPublished

CVE-2026-119144: frappe · Template Injection

Affects frappeSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High : upgrade to 16.21.0 soon.

Data as of 29 Oct 2026, 16:23 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.7
CNA (VulnCheck)CVSS 3.18.8
Patch
Available – fixed in 16.21.0, 15.111.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade frappe to 16.21.0; frappe to 15.111.0; frappe to 16.21.0 or 15.111.0.

Affected software

ProductAffectedFixed in
frappefrappeAffected
  • >=16.0.0 <16.21.0
Fixed in
  • 16.21.0
frappefrappeAffected
  • <15.111.0
Fixed in
  • 15.111.0
PyPIfrappepkg:pypi/frappeOther threatsAffected
  • >=16.0.0 <16.21.0
  • <15.111.0
Fixed in
  • 16.21.0
  • 15.111.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Frappe Framework to version 15.111.0 or later, or 16.21.0 or later, where this vulnerability is fixed. No other mitigations are indicated by the vendor advisory. Applying these official fixes fully addresses the issue.

Description

CVE-2026-119144 is a server-side template injection vulnerability in the Frappe Framework affecting versions before 15.111.0 and 16.x before 16.21.0. It arises because user-controlled message fields are rendered as templates without proper neutralization, allowing an authenticated attacker with common operational privileges to inject and execute arbitrary template expressions on the server.

References

Community reviews

Loading reviews…