Skip to main content
VulnerabilityPublished

CVE-2026-119145: frappe · Path Traversal

Affects frappeSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.4 Critical : upgrade to 16.34.0 as a priority.

Data as of 29 Oct 2026, 16:23 UTC

CVSS 4.0 base score
9.4Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.09.4
CNA (VulnCheck)CVSS 3.19.9
Patch
Available – fixed in 16.34.0, 15.121.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade frappe to 16.34.0; frappe to 15.121.0; frappe to 16.34.0 or 15.121.0.

Affected software

ProductAffectedFixed in
frappefrappeAffected
  • >=16.0.0 <16.34.0
Fixed in
  • 16.34.0
frappefrappeAffected
  • <15.121.0
Fixed in
  • 15.121.0
PyPIfrappepkg:pypi/frappeOther threatsAffected
  • >=16.0.0 <16.34.0
  • <15.121.0
Fixed in
  • 16.34.0
  • 15.121.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Frappe to version 15.121.0 or later if using the 15.x branch, or to version 16.34.0 or later if using the 16.x branch. These versions contain the official fix that properly validates file upload paths to prevent path traversal. No other mitigation is indicated by the vendor advisory.

Description

CVE-2026-119145 is a critical path traversal vulnerability in Frappe versions before 15.121.0 and 16.x before 16.34.0. The flaw arises because the file upload handling does not properly validate destination paths, allowing authenticated attackers to write files outside the intended directory. This can lead to remote code execution on the affected server.

References

Community reviews

Loading reviews…