CVE-2026-119334: pi-hole · Link Following
Affects pi-holeSource CVE Database V5
Not known to be exploited · CVSS 2.2 Low : upgrade to 6.5 when convenient.
Data as of 30 Oct 2026, 20:38 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 2.2 |
|---|
- Patch
- Available – fixed in 6.5
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade pi-hole to 6.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| pi-holepi-hole | Affected
| Fixed in
|
AI-suggested
Upgrade pi-hole to version 6.5 or later, where this vulnerability is fixed. No additional mitigation is required once the upgrade is applied.
Description
A path traversal vulnerability (CWE-59) in pi-hole prior to version 6.5 allows an administrator with the ability to add adlists and place symlinks on the filesystem to bypass file read checks. The gravity.sh script uses curl, sometimes running as root, to normalize URLs, which can cause it to open unintended files with elevated privileges. This issue is fixed in pi-hole version 6.5.
References
- github.com/pi-hole/pi-hole/security/advisories/GHSA-g63w-24cr-p3w6 (opens in a new tab)
- github.com/pi-hole/pi-hole/pull/6719 (opens in a new tab)
- github.com/pi-hole/pi-hole/commit/14554737be53c392abffc69677f6b9df02ae7971 (opens in a new tab)
- github.com/pi-hole/pi-hole/releases/tag/v6.5 (opens in a new tab)