Skip to main content
VulnerabilityPublished

CVE-2026-119335: pi-hole · OS Command Injection

Affects pi-holeSource CVE Database V5

0
Compare

Mentioned vulnerabilities

Not known to be exploited · CVSS 7.8 High : upgrade to 6.5 soon.

Data as of 30 Oct 2026, 20:19 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.17.8
Patch
Available – fixed in 6.5
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade pi-hole to 6.5.

Affected software

ProductAffectedFixed in
pi-holepi-holeAffected
  • <6.5
Fixed in
  • 6.5

AI-suggested

Upgrade pi-hole to version 6.5 or later, where this vulnerability is fixed. No other mitigation is required as the fix addresses the root cause of the command injection.

Description

CVE-2026-119335 is an OS command injection vulnerability in pi-hole versions prior to 6.5. The vulnerability arises from improper validation of the pihole-owned PID file, allowing an attacker with pihole user privileges to craft a malicious PID file that leads to command execution as root. This flaw bypasses previous remediation measures and is fixed in pi-hole version 6.5.

References

Community reviews

Loading reviews…