Skip to main content
VulnerabilityPublished

CVE-2026-120248: Thelia · Cross-site Scripting

Affects TheliaSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.6 Medium : upgrade to 3.1.1 when convenient.

Data as of 1 Nov 2026, 01:21 UTC

CVSS 4.0 base score
4.6Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.04.6
CNA (VulnCheck)CVSS 3.14.8
Patch
Available – fixed in 3.1.1, 1.1.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade Thelia and Thelia Core to 3.1.1; Thelia Back-office Default Twig Template to 1.1.1.

Affected software

ProductAffectedFixed in
TheliaTheliaAffected
  • <3.1.1
Fixed in
  • 3.1.1
TheliaThelia CoreAffected
  • <3.1.1
Fixed in
  • 3.1.1
TheliaThelia Back-office Default Twig TemplateAffected
  • <1.1.1
Fixed in
  • 1.1.1
PackagistTheliapkg:composer/TheliaOther threatsAffected
  • <3.1.1
Fixed in
  • 3.1.1
PackagistThelia Corepkg:composer/Thelia CoreOther threatsAffected
  • <3.1.1
Fixed in
  • 3.1.1
PackagistThelia Back-office Default Twig Templatepkg:composer/Thelia Back-office Default Twig TemplateOther threatsAffected
  • <1.1.1
Fixed in
  • 1.1.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Thelia to version 3.1.1 or later, or 1.1.1 or later, where this vulnerability is fixed. No other mitigations are specified or required once patched.

Description

Thelia versions prior to 3.1.1 contain a stored cross-site scripting (XSS) vulnerability. Authenticated back-office administrators with store update permissions can exploit this by uploading unsanitized SVG images as logo or banner files. These SVG files can include malicious scripts that execute when accessed via the admin or public cache directories, potentially affecting visitors and higher-privileged administrators.

References

Community reviews

Loading reviews…