CVE-2026-120331: TYPO3 Extension "Mail" · Server-Side Request Forgery
Affects TYPO3 Extension "Mail"Source CVE Database V5
Not known to be exploited · CVSS 5.3 Medium : upgrade to 4.2.0 or 3.12.5 when convenient.
Data as of 3 Nov 2026, 11:11 UTC
Thin evidence
One scorer or none| CNA (TYPO3) | CVSS 4.0 | 5.3 |
|---|
- Patch
- Available – fixed in 4.2.0, 3.12.5
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade Extension "Mail" and mediaessenz/mail to 4.2.0 or 3.12.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Extension "Mail"mediaessenz/mail | Affected
| Fixed in
|
| Extension "Mail"mediaessenz/mail | Affected
| Fixed in
|
Packagistmediaessenz/mailpkg:composer/mediaessenz/mailOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade the TYPO3 Extension "Mail" to version 4.2.0 or later, or 3.12.5 or later, where this SSRF vulnerability is fixed. No other mitigation is indicated or required according to the available data.
Description
CVE-2026-120331 is a server-side request forgery (SSRF) vulnerability in the TYPO3 Extension "Mail". The extension fetches content from external URLs, including stylesheets and images, without validating the target host. This allows backend users with access to the mail module to make the server send requests to internal network hosts. The vulnerability affects versions >=4.0.0 <4.2.0 and >=0 <3.12.5 and has been fixed in versions 4.2.0 and 3.12.5. The CVSS 4.0 base score is 5.3, indicating a medium severity level.