Skip to main content
VulnerabilityPublished

CVE-2026-120432: Netpbm · Integer Overflow or Wraparound

Affects NetpbmSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.5 High · fixed in 11.15.08 : patch Netpbm soon.

Data as of 2 Nov 2026, 14:58 UTC

CVSS 4.0 base score
8.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.5
CNA (VulnCheck)CVSS 3.17.8
Patch
Available – fixed in 11.15.08, 11.02.30, 10.86.51
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade Netpbm and the Debian netpbm package to 11.15.08, 11.02.30 or 10.86.51.

Affected software

ProductAffectedFixed in
NetpbmNetpbmAffected
  • >=11.03 <11.15.08
Fixed in
  • 11.15.08
NetpbmNetpbmAffected
  • >=11.0 <11.02.30
Fixed in
  • 11.02.30
NetpbmNetpbmAffected
  • >=10.63 <10.86.51
Fixed in
  • 10.86.51
Debiannetpbmpkg:deb/netpbmOther threatsAffected
  • >=10.63 <10.86.51
  • >=11.0 <11.02.30
  • >=11.03 <11.15.08
Fixed in
  • 10.86.51
  • 11.02.30
  • 11.15.08

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is fixed in Netpbm versions 10.86.51, 11.02.30, and 11.15.08. Users and administrators should upgrade to one of these fixed versions to mitigate the risk. No additional mitigation steps are indicated by the vendor advisory.

Description

CVE-2026-120432 is an integer overflow vulnerability in Netpbm's winicontopam component affecting versions before 10.86.51, 11.02.30, and 11.15.08. The flaw allows attackers to supply crafted icon files with dimensions exceeding 32767, causing 16-bit signed integer wraparound. This leads to negative indexing of row buffers, resulting in heap memory corruption that can cause crashes or potentially enable code execution.

References

Community reviews

Loading reviews…