Skip to main content
VulnerabilityPublished

CVE-2026-120436: Netpbm · Integer Overflow or Wraparound

Affects NetpbmSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.5 High · fixed in 11.15.08 : patch Netpbm soon.

Data as of 2 Nov 2026, 14:58 UTC

CVSS 4.0 base score
8.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.5
CNA (VulnCheck)CVSS 3.17.8
Patch
Available – fixed in 11.15.08, 11.02.30, 10.86.51
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade Netpbm and netpbm/netpbm to 11.15.08, 11.02.30 or 10.86.51.

Affected software

ProductAffectedFixed in
NetpbmNetpbmAffected
  • >=11.03 <11.15.08
Fixed in
  • 11.15.08
NetpbmNetpbmAffected
  • >=11.0 <11.02.30
Fixed in
  • 11.02.30
NetpbmNetpbmAffected
  • <10.86.51
Fixed in
  • 10.86.51
Netpbmnetpbm/netpbmpkg:deb/netpbm/netpbmOther threatsAffected
  • <10.86.51
  • >=11.0 <11.02.30
  • >=11.03 <11.15.08
Fixed in
  • 10.86.51
  • 11.02.30
  • 11.15.08

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches by upgrading Netpbm to version 10.86.51, 11.02.30, or 11.15.08 or later, depending on the version branch in use. These versions contain fixes that address the integer overflow and prevent the heap buffer overflow. No other mitigation is indicated by the vendor advisory.

Description

CVE-2026-120436 is an integer overflow vulnerability in the Netpbm image processing tool, specifically in the jbigtopnm utility. The flaw occurs when processing crafted multi-plane JBIG files with large header dimensions, leading to a heap buffer overflow in the jbg_dec_merge_planes() function. This can cause application crashes or potentially allow code execution. The vulnerability affects Netpbm versions before 10.86.51, all 11.x versions before 11.02.30, and versions 11.03 up to but not including 11.15.08. Fixes are available in versions 10.86.51, 11.02.30, and 11.15.08. The CVSS 4.0 score is 8.5, indicating high severity.

References

Community reviews

Loading reviews…