Skip to main content
VulnerabilityPublished

CVE-2026-120434: Netpbm · Stack-based Buffer Overflow

Affects NetpbmSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.5 High · fixed in 11.15.08 : patch Netpbm soon.

Data as of 2 Nov 2026, 14:58 UTC

CVSS 4.0 base score
8.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.5
CNA (VulnCheck)CVSS 3.17.8
Patch
Available – fixed in 11.15.08, 11.02.30, 10.86.51
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade Netpbm to 11.15.08, 11.02.30 or 10.86.51.

Affected software

ProductAffectedFixed in
NetpbmNetpbmAffected
  • >=11.03 <11.15.08
Fixed in
  • 11.15.08
NetpbmNetpbmAffected
  • >=11.0 <11.02.30
Fixed in
  • 11.02.30
NetpbmNetpbmAffected
  • <10.86.51
Fixed in
  • 10.86.51

AI-suggested

Apply the official fixes by upgrading Netpbm to versions 10.86.51, 11.02.30, or 11.15.08 or later. These versions contain patches that address the stack-based buffer overflow in picttoppm. No other mitigation is indicated by the vendor advisory.

Description

CVE-2026-120434 is a stack-based buffer overflow vulnerability in the Netpbm image processing tool. It affects the picttoppm utility's scanPoly() function, which improperly handles polygon edges in crafted PICT files with more than 5000 points. This can cause a crash or potentially allow code execution. The flaw affects Netpbm versions before 10.86.51, 11.0 up to but not including 11.02.30, and 11.03 up to but not including 11.15.08. Fixed versions are 10.86.51, 11.02.30, and 11.15.08.

References

Community reviews

Loading reviews…