CVE-2026-120757: The HDF Group HDF5 · Out-of-bounds Read
Affects The HDF Group HDF5Source CVE Database V5
Not known to be exploited · CVSS 6.9 Medium : upgrade to 2.3.0 when convenient.
Data as of 3 Nov 2026, 15:58 UTC
Thin evidence
One scorer or none| CNA (HDFG) | CVSS 4.0 | 6.9 |
|---|
- Patch
- Available – fixed in 2.3.0
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:L/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade HDF5 and hdfgroup/hdf5 to 2.3.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| The HDF GroupHDF5 | Affected
| Fixed in
|
GitHubhdfgroup/hdf5pkg:github/hdfgroup/hdf5Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in HDF5 version 2.3.0. Users and administrators should upgrade to version 2.3.0 or later to remediate this vulnerability. No additional mitigation steps are indicated by the vendor advisory.
Description
HDF5 versions prior to 2.3.0 contain a heap buffer over-read vulnerability in the external link traversal function. The flaw arises because the code uses strlen() on user data without validating its length, allowing an attacker to craft a malicious file that causes out-of-bounds reads. This can lead to denial of service and potentially cause the library to use corrupted file or object path names.