Skip to main content
VulnerabilityPublished

CVE-2026-121442: frappe hrms · Insecure Direct Object Reference

Affects frappe hrmsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium : upgrade to 15.61.0 when convenient.

Data as of 3 Nov 2026, 14:58 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.05.3
CNA (VulnCheck)CVSS 3.14.3
Patch
Available – fixed in 15.61.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade hrms and frappe/hrms to 15.61.0.

Affected software

ProductAffectedFixed in
frappehrmsAffected
  • <15.61.0
Fixed in
  • 15.61.0
GitHubfrappe/hrmspkg:github/frappe/hrmsOther threatsAffected
  • <15.61.0
Fixed in
  • 15.61.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Frappe HRMS to version 15.61.0 or later, where this authorization bypass vulnerability has been fixed. No additional mitigations are indicated by the vendor advisory.

Description

CVE-2026-121442 is a permission bypass vulnerability in Frappe HRMS versions before 15.61.0. Authenticated employees can exploit this flaw to access expense advance details of other employees by querying the Expense Claim Advances API without proper authorization checks. This leads to exposure of sensitive financial information. The vulnerability is fixed in version 15.61.0.

References

Community reviews

Loading reviews…