Skip to main content
VulnerabilityPublished

CVE-2026-121819: LY Armeria · Link Following

Affects LY ArmeriaSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.9 Medium : upgrade to 1.43.0 when convenient.

Data as of 6 Nov 2026, 08:05 UTC

CVSS 4.0 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (LY-Corporation)CVSS 4.05.9
Patch
Available – fixed in 1.43.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade LY Armeria to 1.43.0.

Affected software

ProductAffectedFixed in
LY CorporationArmeriaAffected
  • >=1.40 <1.43.0
Fixed in
  • 1.43.0

AI-suggested

Upgrade affected Armeria armeria-xds versions to 1.43.0 or later, where the vulnerability is fixed. No other mitigation or temporary workaround is indicated by the vendor advisory.

Description

CVE-2026-121819 is a medium severity vulnerability in LY Corporation's Armeria library, specifically in armeria-xds versions 1.40.0 through 1.42.0. The issue arises because DataSourcePolicy does not resolve symbolic links when checking filename containment, allowing an attacker controlling or partially controlling the xDS control plane to cause the client to read files outside the intended root directories. This can lead to exposure of header-compatible text secrets in deployments using a credential injector. The vulnerability is fixed in version 1.43.0.

References

Community reviews

Loading reviews…