CVE-2026-121822: LY Armeria · Cross-site Scripting
Affects LY ArmeriaSource CVE Database V5
Not known to be exploited · CVSS 2.4 Low : upgrade to 1.43.0 when convenient.
Data as of 6 Nov 2026, 08:05 UTC
Thin evidence
One scorer or none| CNA (LY-Corporation) | CVSS 4.0 | 2.4 |
|---|
- Patch
- Available – fixed in 1.43.0
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade LY Armeria to 1.43.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| LY CorporationArmeria | Affected
| Fixed in
|
AI-suggested
Upgrade Armeria to version 1.43.0 or later, where this vulnerability is fixed. Until the upgrade, consider disabling directory listing to prevent exposure of file names that could be exploited for stored XSS.
Description
A stored cross-site scripting (XSS) vulnerability exists in LY Corporation's Armeria versions 0.80.0 through 1.42.0. The flaw occurs when directory listing is enabled and attackers control file names, allowing malicious scripts to be stored and executed when a user views the directory listing. This issue is fixed in version 1.43.0.