Skip to main content
VulnerabilityPublished

CVE-2026-121821: LY Armeria · Permissive Cross-domain Security Policy with Untrusted Domains

Affects LY ArmeriaSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium : upgrade to 1.43.0 when convenient.

Data as of 6 Nov 2026, 08:05 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (LY-Corporation)CVSS 4.05.3
Patch
Available – fixed in 1.43.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade LY Armeria to 1.43.0.

Affected software

ProductAffectedFixed in
LY CorporationArmeriaAffected
  • >=0.84.0 <1.43.0
Fixed in
  • 1.43.0

AI-suggested

Upgrade Armeria to version 1.43.0 or later, where this vulnerability is fixed. No other mitigations are indicated by the vendor advisory.

Description

CVE-2026-121821 is a medium severity vulnerability in LY Corporation's Armeria framework versions 0.84.0 through 1.42.0. It involves permissive Cross-Origin Resource Sharing (CORS) policies that fail to enforce configured path restrictions. This allows attacker-controlled websites visited by authenticated users to read sensitive responses from paths that should be excluded when credentials are enabled.

References

Community reviews

Loading reviews…