CVE-2026-123014: iTerm2 · Argument Injection
Affects iTerm2Source CVE Database V5
Mentioned vulnerabilities
Not known to be exploited · CVSS 8.7 High : upgrade to 3.7.7beta2 soon.
Data as of 5 Nov 2026, 05:44 UTC
Thin evidence
One scorer or none| CNA (mitre) | CVSS 4.0 | 8.7 |
|---|
- Patch
- Available – fixed in 3.7.7beta2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 5 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade iTerm2 and gnachman/iterm2 to 3.7.7beta2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| iTerm2iTerm2 | Affected
| Fixed in
|
GitHubgnachman/iterm2pkg:github/gnachman/iterm2Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade iTerm2 to version 3.7.7beta2 or later, where this vulnerability is fixed. Since the issue is resolved in this version, no additional mitigation steps are required.
Description
CVE-2026-123014 is an argument injection vulnerability in iTerm2 versions before 3.7.7beta2. It affects the x-man-page URL handler, allowing an attacker to execute arbitrary commands with the privileges of the logged-in user by tricking the user into opening a crafted URL. The vulnerability arises because percent-encoded NUL characters bypass input sanitization and are converted to whitespace during command-line parsing, enabling injection of additional arguments to the /usr/bin/man command. This includes injecting the -P option to specify an attacker-controlled pager command. The issue is due to an incomplete fix for a previous vulnerability (CVE-2023-46321).