Skip to main content
VulnerabilityPublished

CVE-2026-123487: parse-server · ReDoS

Affects parse-serverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High : upgrade to 9.10.7-alpha.1 soon.

Data as of 6 Nov 2026, 15:26 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.7
CNA (VulnCheck)CVSS 3.17.5
Patch
Available – fixed in 9.10.7-alpha.1, 8.6.115
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade parse-server to 9.10.7-alpha.1; parse-server to 8.6.115; parse-server to 9.10.7-alpha.1 or 8.6.115.

Affected software

ProductAffectedFixed in
parse-communityparse-serverAffected
  • >=9.0.0 <9.10.7-alpha.1
Fixed in
  • 9.10.7-alpha.1
parse-communityparse-serverAffected
  • <8.6.115
Fixed in
  • 8.6.115
npmparse-serverpkg:npm/parse-serverOther threatsAffected
  • >=9.0.0 <9.10.7-alpha.1
  • <8.6.115
Fixed in
  • 9.10.7-alpha.1
  • 8.6.115

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade parse-server to version 8.6.115 or later, or 9.10.7-alpha.1 or later, where the vulnerability is fixed. No other mitigation is required as the fix addresses the root cause.

Description

CVE-2026-123487 is a vulnerability in parse-community's parse-server where user email validation uses a regular expression with quadratic time complexity and no input length limit. This flaw allows an unauthenticated attacker with knowledge of the application ID or a logged-in user to submit a crafted long email address that blocks the Node.js event loop, causing a denial of service. The issue affects parse-server versions before 8.6.115 and versions 9.0.0 up to but not including 9.10.7-alpha.1. A fix is available in versions 8.6.115 and 9.10.7-alpha.1.

References

Community reviews

Loading reviews…